Monthly Archives: January 2010

Support discontinued for Windows® 98/ME/NT4/2000

Support is no longer available for Spectaculator running on the above versions of Windows. Windows® Vista and XP (32-bit variants) are the only versions of Windows Spectaculator is currently supported on. Although Spectaculator runs perfectly well on Windows® 7, it … Continue reading

Posted in News | Leave a comment